iSpring scorm package and "Load from xml:" error

Please report here problems and bugs
Post Reply
User avatar
murat
FormaLms User
Posts: 108
Joined: Fri Oct 12, 2012 6:28 pm
Version: forma.lms 2.0

iSpring scorm package and "Load from xml:" error

Post by murat »

iSpring scorm package, the system is loaded the error.Why?

Error text is "Load from xml:<?xml version="1.0" encoding="UTF-8"?>..."
Attachments
iSpring scorm package is error
iSpring scorm package is error
scorm hata.png (12.58 KiB) Viewed 334 times
Hello,I'm Murat. If you need me, you can contact my mail

wanadli
Newbie
Posts: 6
Joined: Sun Oct 14, 2012 5:00 pm

Re: iSpring scorm package and "Load from xml:" error

Post by wanadli »

Try this ...

1. Open your imsmanifest file (the one created by iSpring)

2. Look at line 22: <item identifier="item" identifierref="resource">

3. Change 'item' to something else ... say 'xxx'.

4. Zip/package your files and try to upload again.

Let me know if it works for you.

wanadli
Newbie
Posts: 6
Joined: Sun Oct 14, 2012 5:00 pm

Re: iSpring scorm package and "Load from xml:" error

Post by wanadli »

If you are lazy to re-upload the SCORM package again, then try this quick fix:

1. open your 'learning_scorm_items' table.

2. Change 'item_identifier' column value from 'item' to 'xxx' (or any other sequence of characters that you fancy)

That's all.

User avatar
murat
FormaLms User
Posts: 108
Joined: Fri Oct 12, 2012 6:28 pm
Version: forma.lms 2.0

Re: iSpring scorm package and "Load from xml:" error

Post by murat »

Thank you very much.

Both of which it actually worked.
Hello,I'm Murat. If you need me, you can contact my mail

User avatar
max
FormaLms Guru
Posts: 2178
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: iSpring scorm package and "Load from xml:" error

Post by max »

Thank you wanadli!
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

Post Reply