SCORM object not marked as "completed"

Backend functionalities: user management, course management, reports, certificates, etc.
Post Reply
lorenzo.passarini
Newbie
Posts: 4
Joined: Thu Apr 30, 2020 10:44 pm

SCORM object not marked as "completed"

Post by lorenzo.passarini »

I have noted that SCORM object has been marked as "completed" only if it contains a Quiz. The first time you run it you can see the orange check box that means it is initiated. But it is never market in green, so it is never considered completed.
On the other hand, if I use a SCORM object containing a Quiz and the minimum score is reached, then the green check box will appear.

Anyone can tell me if Forma requires both CMI commands "Success" and "Completed" from the SCORM object ?

Many thanks in advance

User avatar
max
FormaLms Guru
Posts: 2351
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: SCORM object not marked as "completed"

Post by max »

Hi Lorenzo,

it's not exactly like that. Of course a Scorm can be set as completed on Forma even if it doesn't include a quiz.
Don't know what authoring tools you are using, but in our experience this is what works correctly with Articulate, in the scorm publishing options:

- completed/incomplete if you don't have a quiz (or, better, if the completion is tracked by the number of slides)
- passed/failed if the completion is tracked by the results slide (the result slide is used when you have one or more quizzes and communicates to the LMS if the user has reached the pass mark).

I don't normally use iSpring, but many customers and Forma users have been using it correctly on Forma, with or without quiz. And the same for Captivate, Rise and other tools such as eXe.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

lorenzo.passarini
Newbie
Posts: 4
Joined: Thu Apr 30, 2020 10:44 pm

Re: SCORM object not marked as "completed"

Post by lorenzo.passarini »

Hi Massimiliano,
Many thanks for your reply.
I am using Camtasia to generate SCORM 1.2 packages. Just to give you the clear picture of what has happened, I have created 3 very simple SCORM packages: L1, L2, L3 (you can download the zip files at the following link: https://cloud.klabs.it/index.php/s/sFRetw8un7z1SZE ). All three packages contain a short video. The SCORM options are set as “completed” if the user watched more than 95% of the video.
The first two packages (L1 , L2) do not contain any quiz, so the manifest option looks like what you can see in the attached picture Manifest_options.jpg
Only in the third file (L3) I have inserted a Quiz with passing score set at 80%. You can see the manifest options in the attached picture Manifest_options_Quiz.jpg
After completed all the three object the course progress shows only 33% as you can see in the attached picture Forma_result.jpg. The green check box appears only on L3. L1 and L2 are not completed even if I have watch the full video.

Please help me to solve this problem.
Many thanks
Best regards
Lorenzo
Attachments
Manifest_options.JPG
Manifest_options_Quiz.JPG
Forma_result.JPG

pjmanly
Newbie
Posts: 3
Joined: Thu Nov 14, 2019 7:39 pm
Version: forma.lms 2.0

Re: SCORM object not marked as "completed"

Post by pjmanly »

I have had the same problem develop where SCORM objects do not show as completed, even though the student has completed the module. This is a new problem. Existing courses used to work correctly (SCORM object showed with green check mark), but they no longer work correctly.

We discovered the problem when a user reported they could not take a test for a course. I asked him to make sure they had viewed all the slides (SCORM object), and he said he did but still could not take the test. I went on to the course and could not get it to show it was completed (green check mark) even though I had viewed every slide. I created test SCORM objects using SCORM 1.2 and SCORM 2004 but nothing would work so that when I viewed the slides, the object showed as completed in the LMS.

I have modified the course to eliminate the prerequisite of completing the SCORM object before the student can take the test (the test is created in FormaLMS), but I would like to find a fix for this problem.

User avatar
max
FormaLms Guru
Posts: 2351
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: SCORM object not marked as "completed"

Post by max »

Hi pjmanly,
it's 2 different, unrelated issues.

Lorenzo's one is related to Camtasia only, where we know there have always been problems.

Your issue has already been documented and it's related to a recent update of some browsers. The solution has been released about a month ago https://forum.formalms.org/16/13698.html
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

pjmanly
Newbie
Posts: 3
Joined: Thu Nov 14, 2019 7:39 pm
Version: forma.lms 2.0

Re: SCORM object not marked as "completed"

Post by pjmanly »

I applied the patch by replacing the ScormApi.js script, but it did not fix the problem.

pjmanly
Newbie
Posts: 3
Joined: Thu Nov 14, 2019 7:39 pm
Version: forma.lms 2.0

Re: SCORM object not marked as "completed"

Post by pjmanly »

My error. I had to clear my cache in Chrome. Now it works. I also checked and it works in Firefox also.

Post Reply