The Elearning Community • No courses showing on admin page
Page 1 of 1

No courses showing on admin page

Posted: Wed Aug 18, 2021 1:19 pm
by gianniteixeira
Hello all,
I just freshly installed forma LMS and when i create a course it doesn't show in the course table. I will send a screen shot so that you guys can have a look. Does anyone know what could be the problem? It just says no records found.

Thanks in advance.

Re: No courses showing on admin page

Posted: Wed Aug 18, 2021 2:21 pm
by alfa24
What kind of course did you create? Is it a classroom one?

Re: No courses showing on admin page

Posted: Wed Aug 18, 2021 2:44 pm
by gianniteixeira
I created a e-learning one. The courses will show up in the main page but on the admin area to manage courses they don't show up, the table is empty. So if i want to edit them I can't.

Same problem with the category. When i create one, the system accepts it and then once i refresh the page it do not show anymore. I'm wondering if its something related with the data base or anything like that.

Re: No courses showing on admin page

Posted: Wed Aug 18, 2021 2:48 pm
by alfa24
I should be on your instance to help.
But first, you could provide some info about your server, such as PHP and mysql version.
Also Apache error.log could offer some hints.

Re: No courses showing on admin page

Posted: Wed Aug 18, 2021 2:53 pm
by gianniteixeira
alfa24 wrote:
Wed Aug 18, 2021 2:48 pm
I should be on your instance to help.
But first, you could provide some info about your server, such as PHP and mysql version.
Also Apache error.log could offer some hints.
Thank you, I will send you an attachment.

Re: No courses showing on admin page

Posted: Wed Aug 18, 2021 3:21 pm
by alfa24
What about Apache error.log?
I'd try to debug mysql for that safe mode and SQL mode, but server root privileges are needed.
You may find topics in the forums regarding sql_mode directive.

Re: No courses showing on admin page

Posted: Wed Aug 18, 2021 3:29 pm
by gianniteixeira
alfa24 wrote:
Wed Aug 18, 2021 3:21 pm
What about Apache error.log?
I'd try to debug mysql for that safe mode and SQL mode, but server root privileges are needed.
You may find topics in the forums regarding sql_mode directive.
I had a look at the Apache logs and i can't see anything out of the ordinary. There were a few errors but don't think anything related to this problem that i'm experiencing. Will try and have a look at that SQL mode. Thank you.

Re: No courses showing on admin page

Posted: Wed Aug 18, 2021 4:01 pm
by gianniteixeira
Problem solved the SQL mode was wrong. It should be:

NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

Thanks for all your help.

Re: No courses showing on admin page

Posted: Wed Aug 18, 2021 4:02 pm
by alfa24
You're welcome.

This site uses cookies.

Some of the cookies we use are essential for parts of the site to operate and have already been set. We also use Google Analytics scripts, which all use cookies.
You may delete or block all cookies from this site in your browser options.