Problem adding iframe Source Code to HTML Learning Object

Anything about what happens on the user and teacher side
Post Reply
docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Problem adding iframe Source Code to HTML Learning Object

Post by docebogal »

I am having a problem adding Source Code to an HTML LO as an admin.
No problem when logged-in as Super Admin, but only have problem when logged-in as regular admin.

Here's how the problem shows itself in v4.05:
Inside Course, under teacher area, create an HTML LO.
Click on the "HTML" icon in the icon bar.
Inside the HTML Source Editor, add standard html to link to video on another site; Vimeo, for example:

(<br /><iframe src="/https://player.vimeo.com/video/
12345678?title=0&byline=0&portrait=0&autoplay=1" frameborder="0" width="720" height="540"></iframe>)

(the video # has been changed in the html above, but otherwise correct code.)
Click update, click save changes.
As mentioned before, the above scenario works fine when logged-in as a Super Admin, but not as a Normal Admin.
When making the above edit as normal Admin, after you save changes, and go back into edit mode, the code has been erased.
- Looked at all settings under Admin profile, and can't' figure it out?
Is there a way to enable a regular Admin to do the above? (allow linking, etc.)
Please help
What do you recommend?

User avatar
alberto
FormaLms Guru
Posts: 1048
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Problem adding iframe Source Code to HTML Learning Objec

Post by alberto »

In administration, under main > configuration > settings > advanced there is an option to "Allow administrator media management in the editor", see if it is checked...
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: Problem adding iframe Source Code to HTML Learning Objec

Post by docebogal »

Yes, it already had a checkmark. Any other ideas?
thanks.

User avatar
alberto
FormaLms Guru
Posts: 1048
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Problem adding iframe Source Code to HTML Learning Objec

Post by alberto »

The iframe tag is blocked by the html purifier, you will need to modify it in onrder to allow iframes
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

jasmines
Senior Boarder
Posts: 277
Joined: Fri May 03, 2013 12:29 pm

Re: Problem adding iframe Source Code to HTML Learning Objec

Post by jasmines »

Are you sure about htmlpurifier? I'm able to embed iframes without problems.

Post Reply