Tinymce not loading after update

Anything about what happens on the user and teacher side
marius
FormaLms User
Posts: 71
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Tinymce not loading after update

Post by marius »

Good day

I've updated from V2.3 to V2.4.5 without issues during the update. However after the update the Tinymce gui is not loading on any of the edit screens. The system only shows the Texteditor screen.

I've made sure that it is selected within the configuration - main options , and saved the config again but it still does not load...

alfa24
Senior Boarder
Posts: 1382
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by alfa24 »

Do you find errors in console?
I'm Jasmines, the One. If you need, you can contact me.

marius
FormaLms User
Posts: 71
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by marius »

Good day.
I've chaned my php config to display errors but do not see any error when the editor is supposed to load.

I've gone through the pgp error logfile and can not find any trace of tinymce specifically. There is however a lot of references to "undefined variable" and "undefined index" right after I complete the update to 2.4.5 - attached to this post.

Below is the output from the browser console window:

index.php:689 GET https://www.googletagmanager.com/gtag/j ... 69RY6SWGMB net::ERR_BLOCKED_BY_CLIENT
index.php:36 GET https://*serverurl*/addons/jquery/core/ui/js/i18n/datepicker-en;%20en-us.js net::ERR_ABORTED 404 (Not Found)
main.js:1 100
DevTools failed to load source map: Could not load content for chrome-extension://gannpgaobkkhmpomoijebaigcapoeebl/bundle.min.js.map: HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME
DevTools failed to load source map: Could not load content for https://*serverurl*/addons/jquery/select/bootstrap-select.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load source map: Could not load content for https://*serverurl*/addons/jquery/bootstrap/css/bootstrap.min.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load source map: Could not load content for https://*serverurl*/addons/jquery/bootstrap/css/bootstrap-theme.min.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Attachments
php_error_log_extract.zip
(11.33 KiB) Not downloaded yet

alfa24
Senior Boarder
Posts: 1382
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by alfa24 »

I'm Jasmines, the One. If you need, you can contact me.

marius
FormaLms User
Posts: 71
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by marius »

I've implemented the changes you recommend but only get a server 500 error. console output is as follows:
crbug/1173575, non-JS module files deprecated.
(anonymous) @ VM78:6772

marius
FormaLms User
Posts: 71
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by marius »

I've corrected the code as per "cpetrovay" and it fixes the datepicker error. However, tinymce still does not load on any of the editing pages...

marius
FormaLms User
Posts: 71
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by marius »

I've also tested the YUI editor and it also does not load correctly - get the following console output when the YUI editor is selected and a edit page is loaded:

GET https://*rooturl*/appCore/addons/yui/assets/skins/sam/skin.css net::ERR_ABORTED 404 (Not Found)
main.js:1 100
DevTools failed to load source map: Could not load content for chrome-extension://gannpgaobkkhmpomoijebaigcapoeebl/bundle.min.js.map: HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME
DevTools failed to load source map: Could not load content for https://*rooturl*/addons/jquery/select/bootstrap-select.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load source map: Could not load content for https://*rooturl*/addons/jquery/bootstrap/css/bootstrap.min.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load source map: Could not load content for https://*rooturl*/addons/jquery/bootstrap/css/bootstrap-theme.min.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

alfa24
Senior Boarder
Posts: 1382
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by alfa24 »

Those errors are not related with Tinymce.
There should be something related in console or in PHP error log.
I'm Jasmines, the One. If you need, you can contact me.

marius
FormaLms User
Posts: 71
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by marius »

There is nothing new in the php error log. Also again tested it with the PHP config set to display_errors = ON - but nothing is shown on the page after loading...

alfa24
Senior Boarder
Posts: 1382
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Tinymce not loading after update

Post by alfa24 »

I should be on your instance to investigate. There's something you're not seeing.
I'm Jasmines, the One. If you need, you can contact me.

Post Reply