Windows server 2016 IIS 10.0 help needed

Install and configure FormaLMS and DoceboCE
Post Reply
User avatar
Crimzin
Newbie
Posts: 12
Joined: Wed Nov 13, 2019 7:31 am

Windows server 2016 IIS 10.0 help needed

Post by Crimzin »

Hi All,

I am currently doing an installation on Windows server 2016 IIS 10.0

I can run the install pages but I get stuck at step 2.
    Does anyone now the settings for the permissions that needs to be set on the files and folders.
      What should the current version of PHP be? 7.0.x is not available on the PHP site anymore.

      Step 2: System Check
      Server information
      Server software : : Microsoft-IIS/10.0
      PHP Version : : 7.1.33
      Mysql Client Version : : 5.0.12
      Multibyte Support: ON
      mime_content_type() support: OFF
      Fileinfo support : OFF Consider this warning only if you need to use fileinfo
      Ldap : : OFF Consider this warning only if you need to use LDAP
      Openssl : : ON
      Site Timezone: Europe/Minsk
      PHP Information :
      magic_quotes_gpc : : OFF
      Safe mode : : OFF
      register_global : : OFF
      allow_url_fopen : : ON
      allow_url_include : : OFF
      upload_max_filsize : : 2M
      post_max_size : : 8M
      max_execution_time : : 300s
      Some directory where files are stored does not exist or does not have correct permission
      files/tmp
      files/common/comment
      files/common/iofiles
      files/common/users
      files/appCore/field
      files/appCore/photo
      files/appCore/newsletter
      files/common/users
      files/appLms/certificate
      files/appLms/chat
      files/appLms/forum
      files/appLms/htmlpages
      files/appLms/item
      files/appLms/label
      files/appLms/message
      files/appLms/project
      files/appLms/repo_light
      files/appLms/sponsor
      files/appLms/test
      Certain files does not have adequate permission
      config.php

      alfa24
      Senior Boarder
      Posts: 931
      Joined: Fri Nov 24, 2017 8:45 am
      Version: forma.lms 1.4.2

      Re: Windows server 2016 IIS 10.0 help needed

      Post by alfa24 »

      old PHP archives: https://windows.php.net/downloads/releases/archives/

      For mime_type support:

      open php.ini, find and uncomment

      Code: Select all

      ;mime_magic.debug = On
      to:

      Code: Select all

      mime_magic.debug = On
      and

      Code: Select all

      ;extension=php_fileinfo.dll
      to:

      Code: Select all

      extension=php_fileinfo.dll
      open httpd.conf, find and uncomment

      Code: Select all

      #LoadModule mime_magic_module modules/mod_mime_magic.so
      to:

      Code: Select all

      LoadModule mime_magic_module modules/mod_mime_magic.so
      Reload apache/IIS.
      I'm Jasmines, the One. If you need, you can contact me.

      JBurg
      Newbie
      Posts: 5
      Joined: Mon Jun 15, 2020 6:57 pm

      Re: Windows server 2016 IIS 10.0 help needed

      Post by JBurg »

      Hey,

      I am having the exact same issue. I can not seem to find any of the lines you suggested changing above in my php.ini file. As well, if I change those lines, does it fix the permissions issues or is there something else I have to do?

      Thanks!

      alfa24
      Senior Boarder
      Posts: 931
      Joined: Fri Nov 24, 2017 8:45 am
      Version: forma.lms 1.4.2

      Re: Windows server 2016 IIS 10.0 help needed

      Post by alfa24 »

      If you're having the "same exact" issue, you should be able to find the same exact lines.
      Otherwise, please provide the infos above.
      I'm Jasmines, the One. If you need, you can contact me.

      JBurg
      Newbie
      Posts: 5
      Joined: Mon Jun 15, 2020 6:57 pm

      Re: Windows server 2016 IIS 10.0 help needed

      Post by JBurg »

      Here is the info. I think the only difference is the PHP version.

      ---------------------------------------

      Step 2: System Check

      Server information
      Server software : : Microsoft-IIS/10.0
      PHP Version : : 7.0.33
      Mysql Client Version : : 5.0.12
      Multibyte Support: ON
      mime_content_type() support: OFF
      Fileinfo support : OFF Consider this warning only if you need to use fileinfo
      Ldap : : OFF Consider this warning only if you need to use LDAP
      Openssl : : ON
      Site Timezone: America/New_York

      PHP Information :
      magic_quotes_gpc : : OFF
      Safe mode : : OFF
      register_global : : OFF
      allow_url_fopen : : ON
      allow_url_include : : OFF
      upload_max_filsize : : 2M
      post_max_size : : 8M
      max_execution_time : : 300s

      Some directory where files are stored does not exist or does not have correct permission
      files/tmp
      files/common/comment
      files/common/iofiles
      files/common/users
      files/appCore/field
      files/appCore/photo
      files/appCore/newsletter
      files/common/users
      files/appLms/certificate
      files/appLms/chat
      files/appLms/forum
      files/appLms/htmlpages
      files/appLms/item
      files/appLms/label
      files/appLms/message
      files/appLms/project
      files/appLms/repo_light
      files/appLms/sponsor
      files/appLms/test

      Certain files does not have adequate permission
      config.php

      AndrewL
      Newbie
      Posts: 8
      Joined: Mon Jun 15, 2020 9:30 pm

      Re: Windows server 2016 IIS 10.0 help needed

      Post by AndrewL »

      Hello,

      I installed Forma successfully on an Apache server, but when I tried to install it on IIS, I also get this message:

      mime_content_type() support: OFF

      I followed the instructions in alpha24's reply to the original question, but I ran into a problem. The extension=php_fileinfo.dll line was easily found in php.ini and already uncommented; no problem. The mime_magic.debug = On line isn't in the php.ini file in the version I'm using (7.0.33) or the version the original poster is using, but that's no problem, I just added it.

      But the problem is with the LoadModule mime_magic_module modules/mod_mime_magic.so line. It's there in the httpd.conf file for Apache, but, of course, there is no httpd.conf file in IIS. I looked in the applicationHost.conf file, but it wasn't there and I suddenly realized that I'd need to figure out what the IIS equivalent of the mod_mime_magic module is.

      After some Googling, I'm still uncertain what to do in IIS. Can anyone tell me how to solve the problem specifically for IIS? Crimzin, how did you get it working with IIS?

      Here are my details from page 2 of the installer:

      Server information
      Server software : : Microsoft-IIS/10.0
      PHP Version : : 7.0.33
      Mysql Client Version : : 5.0.12
      Multibyte Support: ON
      mime_content_type() support: OFF
      Fileinfo support : OFF Consider this warning only if you need to use fileinfo
      Ldap : : OFF Consider this warning only if you need to use LDAP
      Openssl : : ON
      Site Timezone: America/New_York

      PHP Information :
      magic_quotes_gpc : : OFF
      Safe mode : : OFF
      register_global : : OFF
      allow_url_fopen : : ON
      allow_url_include : : OFF
      upload_max_filsize : : 2M
      post_max_size : : 8M
      max_execution_time : : 300s


      Thank you.

      alfa24
      Senior Boarder
      Posts: 931
      Joined: Fri Nov 24, 2017 8:45 am
      Version: forma.lms 1.4.2

      Re: Windows server 2016 IIS 10.0 help needed

      Post by alfa24 »

      I'm Jasmines, the One. If you need, you can contact me.

      User avatar
      Crimzin
      Newbie
      Posts: 12
      Joined: Wed Nov 13, 2019 7:31 am

      Re: Windows server 2016 IIS 10.0 help needed

      Post by Crimzin »

      Thank you,

      I figured it out.

      once you do the upgrade you need to redo the PHP config. it clears the settings.

      Thank you for the replies.

      Kind regrds,
      Crim

      Post Reply