The Elearning Community • Installation Error
Page 1 of 1

Installation Error

Posted: Fri Jan 03, 2020 9:15 am
by pravinu
I am using php 7.2 and on Step 2 I see next step button disabled, please check the attached screenshot.
Screen Shot 2020-01-03 at 1.43.51 PM.png

Re: Installation Error

Posted: Fri Jan 03, 2020 9:25 am
by alfa24
Forma needs PHP < 7.1, better if < 7.0.11

Re: Installation Error

Posted: Fri Jan 03, 2020 9:38 am
by pravinu
Ohh I have existing server with other softwares installed, any other way or workaround?

Re: Installation Error

Posted: Fri Jan 03, 2020 9:45 am
by alfa24
You could try to bypass the control (can't say how many things in Forma will stop working, as my versions are deeply changed and now compatibles with 7.3).
To do this, find the following in /install/controllers/Step2Controller.php:

$res['php']=((version_compare(PHP_VERSION, '5.2.0', '>=') && version_compare(PHP_VERSION, '7.0.11', '<')) ? 'ok' :
((version_compare(PHP_VERSION, '7.0.11', '>=') && version_compare(PHP_VERSION, '7.1.0', '<')) ? 'warn' : 'err' ));

and change it to:

$res['php']='ok';

Re: Installation Error

Posted: Sun Jan 12, 2020 3:01 pm
by hakangur
We managed this by adding the following line into the .htaccess file:

AddHandler application/x-httpd-php56 .php

I do not know if it will work under all PHP installations.

By the way, once FormaLMS is installed, switching back to PHP 7+ is possible.

Re: Installation Error

Posted: Wed Nov 11, 2020 6:52 pm
by petermourra
hello, I have downgraded my php to the recommended and still cannot go past step 2, ive tried every version since 5.x.x

Re: Installation Error

Posted: Wed Nov 11, 2020 7:26 pm
by alfa24
It can be a PHP setting or mySQL. You need to debug

This site uses cookies.

Some of the cookies we use are essential for parts of the site to operate and have already been set. We also use Google Analytics scripts, which all use cookies.
You may delete or block all cookies from this site in your browser options.