site refers to itself as ip not hostname

Install and configure FormaLMS and DoceboCE
Post Reply
evan@canalytica.ca
Newbie
Posts: 1
Joined: Thu Oct 01, 2020 3:31 am

site refers to itself as ip not hostname

Post by evan@canalytica.ca »

Hey All,

I have installed and configured the forma lms 2.2.1 and it works very well - however I've run into an issue running it under https. some links are generated with the ip address (https://123.123.123.123/appLms....), and not the hostname (https://host.name.com/appLms....) causing tls errors (my certificate is named and not by ip).

is there a way to disable this, or debug it?

alfa24
Senior Boarder
Posts: 1133
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: site refers to itself as ip not hostname

Post by alfa24 »

It's not a forma issue.
It's probably a misconfiguration of your webserver.
Could you provide detail of what urls are generated with ip instead of hostname?
I'm Jasmines, the One. If you need, you can contact me.

scubatricky
FormaLms User
Posts: 52
Joined: Wed Oct 21, 2020 11:43 pm

Re: site refers to itself as ip not hostname

Post by scubatricky »

evan@canalytica.ca wrote:
Wed Jan 13, 2021 9:38 pm
Hey All,

I have installed and configured the forma lms 2.2.1 and it works very well - however I've run into an issue running it under https. some links are generated with the ip address (https://123.123.123.123/appLms....), and not the hostname (https://host.name.com/appLms....) causing tls errors (my certificate is named and not by ip).

is there a way to disable this, or debug it?
Most likely this is a canonical issue with the server. If you're running Apache then you'll want to backup yout httpd.conf, check that mod_rewrite is enabled and added a rewrite rule for the ip address your accessing. It'll be .htaccess that 90% of the time is causing the problem.

Post Reply