3.0 upgrade

Install and configure FormaLMS and DoceboCE
Graeme59
FormaLms User
Posts: 60
Joined: Thu May 05, 2016 6:53 am
Version: forma.lms 2.0
Location: UK
Contact:

Re: 3.0 upgrade

Post by Graeme59 »

Hi Alberto,
Just spoke to my hosting company who informed me the version of 10.2.33-MariaDB running on my Managed VPS is the equivalent of MySql5.7 will 3.0 run on this?
Cheers
Graeme

alfa24
Senior Boarder
Posts: 1347
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: 3.0 upgrade

Post by alfa24 »

Yes it will.
I'm Jasmines, the One. If you need, you can contact me.

Graeme59
FormaLms User
Posts: 60
Joined: Thu May 05, 2016 6:53 am
Version: forma.lms 2.0
Location: UK
Contact:

Re: 3.0 upgrade

Post by Graeme59 »

Hi Team,
I am still struggling to upgrade any live platforms to Forma 3.0. My Managed VPS runs sql vers: 5.5.5-10.2.33-MariaDB-log.
I have checked and I am unable to change this.

However.
If I create a new site with no content in 2.3.1 or 2.4.3 or 2.4.4 and upgrade to 3.0 it works perfectly but when I attempt to upgrade a live site it sticks at page 2 with 5.5.5 highlighted in red.

Alpha24 very kindly directed me to a workaround which once translated to English is "Act on the field, remove the default value or change the type of field, or a trigger must be placed to manage the automatic updating of the column instead of the default of mysql." Sadly being a trainer and not a blackbelt in sql, in the words of Ultravox in the classic song Vienna "This means nothing to me".

Is there a simpler way to get around this, I have never had an issue before upgrading it has always been straightforward.
:(
Cheers
Graeme

alfa24
Senior Boarder
Posts: 1347
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: 3.0 upgrade

Post by alfa24 »

Why can't you upgrade mysql?
For the workaround to be applied, you need a db admin who can investigate and alter the db structure for you.
If you need, I'm at your service.
Unfortunately I can't do the analysis and offer the fix for free.
I'm Jasmines, the One. If you need, you can contact me.

User avatar
alberto
FormaLms Guru
Posts: 1066
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: 3.0 upgrade

Post by alberto »

Graeme59 wrote:
Sun Nov 07, 2021 10:48 am
Hi Team,
I am still struggling to upgrade any live platforms to Forma 3.0. My Managed VPS runs sql vers: 5.5.5-10.2.33-MariaDB-log.
I have checked and I am unable to change this.

However.
If I create a new site with no content in 2.3.1 or 2.4.3 or 2.4.4 and upgrade to 3.0 it works perfectly but when I attempt to upgrade a live site it sticks at page 2 with 5.5.5 highlighted in red.

Hi Graeme, try asking your provider to upgrade your sql version, they should allow upgrading to newer versions, especially because version 5.5 is deprecated since 3 years...
https://endoflife.software/applications/databases/mysql
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

GEWadmin
Newbie
Posts: 1
Joined: Fri Nov 12, 2021 12:03 pm

Re: 3.0 upgrade

Post by GEWadmin »

I am running the following versions.

Server information
Server software : : Microsoft-IIS/10.0
PHP Version : : 7.4.13
MySQL Client Version : : 7.4.13
MySQL Server Version : : 8.0.21
Multibyte Support: ON
mime_content_type() support: ON
Ldap : : ON
Openssl : : ON
Site Timezone: Europe/Minsk
PHP Information :
magic_quotes_gpc : : OFF
Safe mode : : OFF
register_global : : OFF
allow_url_fopen : : ON
allow_url_include : : OFF
upload_max_filsize : : 2M
post_max_size : : 8M
max_execution_time : : 300s

User avatar
alberto
FormaLms Guru
Posts: 1066
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: 3.0 upgrade

Post by alberto »

Hi, MySql 8 is not fully tested yet, prefer version 5.7
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

Graeme59
FormaLms User
Posts: 60
Joined: Thu May 05, 2016 6:53 am
Version: forma.lms 2.0
Location: UK
Contact:

Re: 3.0 upgrade

Post by Graeme59 »

Hi Alberto
The db running on my managed VPS is 10.2.33-MariaDB-log which was only released on 2020-08-10 and is due for redundancy end of 2022. It is apparently the equivalent of 5.7. the only available upgrade is 10.4 which is MySQL 8

I have tried the Upgrade twice on a live site both had to be recovered and as you can imagine there were a few nervous moments
On page 5 Upgrade in progress just sits, nothing happens, should there be an upgrade animation on this page?

Is it possible someone could explain Alpha24's Workaround so I can pass it on to the 'My20i' hosting tech team as "Intervienire sul campo, togliere il valore di default o cambiare il tipo di campo, oppure va disposto un trigger che gestisca l'aggiornamento automatico della colonna anziché il default di mysql." apparantly once translated on google it seems to loose its context. (that is not a reflection on Alpha24's work more on Googles translation)

Have a great evening
Graeme

alfa24
Senior Boarder
Posts: 1347
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: 3.0 upgrade

Post by alfa24 »

The concept is: one should analyze and alter the db structure to get rid of certain issues. It's more simple to act on the system. I'm pretty sure you're configuration is ok and some checks in forma code could be bypassed hardcode.
Unfortunately, 3.0 code is not free for me to replicate your scenario, but if you need my help in your environment, I'm available.
I'm Jasmines, the One. If you need, you can contact me.

Post Reply