The Elearning Community • Fresh Instal of 4.0.5
Page 1 of 1

Fresh Instal of 4.0.5

Posted: Sun Jul 21, 2013 9:32 am
by pkimemiah
When I go to the step three am unable to proceed

I have

OS Red Hat Enterprise Edition 5
using user root

Step 2: Information
Server information

* Server software : : Apache/2.2.3 (Red Hat)
* PHP Version : : 5.4.7
* Mysql Client Version : : 5.0.10
* Multibyte Support: OFF
* mime_content_type() support: ON
* Ldap : : ON

PHP Information :

* magic_quotes_gpc : : OFF
* Safe mode : : OFF
* register_global : : OFF
* upload_max_filsize : : 2M
* post_max_size : : 8M
* max_execution_time : : 30s


Looks like I have to set Multibye to ON....how do you do that ....please help

Re: Fresh Install of 4.0.5

Posted: Sun Jul 21, 2013 9:49 pm
by pkimemiah
Solved the problem

Installed PHP from Oracle https://oss.oracle.com/projects/php/dis ... ation.html with mbstring rpm file

Packages installed are

php54-5.4.7-1.el5
php54-cli-5.4.7-1.el5
php54-ldap-5.4.7-1.el5
php54-common-5.4.7-1.el5
php54-pdo-5.4.7-1.el5
php54-mysql-5.4.7-1.el5
php54-mbstring-5.4.7-1.el5

The MySQL Datbase was set to MYSQL40 mode since default for MySQL 5.6 is strict mode.

mysql> set @@global.sql_mode ='MYSQL40';

I was able to advance to step 6/7

Step 6: Database data setup
Database
loading Importing database

Languages
loading English

it has been there for +1 hour.

What could be the problem? or should I just wait?

Re: Fresh Instal of 4.0.5

Posted: Mon Jul 22, 2013 8:00 am
by pkimemiah
Problem Solved

Used PHP 5.4.7 from Oracle Red Hat and it worked

Set MySQL 5.7 to work in "ANSI" mode. I had previously used "MYSQL40"

mysql set @@global.sql_mode = "ANSI"; // not this is temporary , resets back when you re-boot

I hope this helps some one else

Regards

Re: Fresh Instal of 4.0.5

Posted: Mon Jul 22, 2013 11:25 am
by alberto
Hi pkimemiah, thanks for your feedbak.
With php 5.4 you may encounter some issue on multilanguage installations, 5.3 is a better choice at the moment

Re: Fresh Instal of 4.0.5

Posted: Sun Aug 14, 2016 7:29 am
by mmefectiva
You have MySQL strict mode enabled; forma.lms doesn't support it, so please turn it off
In OSX this is the solution for MYSQL strict:
created a /etc/mysql/my.cnf with the following contents:-
[mysqld]
sql_mode=NO_ENGINE_SUBSTITUTION
Source:
http://stackoverflow.com/questions/1876 ... e-in-mysql

This site uses cookies.

Some of the cookies we use are essential for parts of the site to operate and have already been set. We also use Google Analytics scripts, which all use cookies.
You may delete or block all cookies from this site in your browser options.