Errore _DB_NOT_UTF8

Installazione, configurazione generale, notifiche, API, lingue, problemi server
onorato
Newbie
Posts: 22
Joined: Sun Feb 22, 2015 7:44 pm

Errore _DB_NOT_UTF8

Post by onorato »

Salve.
Ho appena attivato un nuovo dominio su Aruba e sto cercando di installare Forma 2.3.
Al passo 4 mi viene riportato l'errore _DB_NOT_UTF8.
Specifico che il database è impostato come uft_general_ci.
Ho altre installazioni di forma su Aruba ed i DB sono impostati allo stesso modo.
Perché ora mi da problemi?

alfa24
Senior Boarder
Posts: 966
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Errore _DB_NOT_UTF8

Post by alfa24 »

Ciao, devi impostarlo in utf8_unicode_ci
I'm Jasmines, the One. If you need, you can contact me.

onorato
Newbie
Posts: 22
Joined: Sun Feb 22, 2015 7:44 pm

Re: Errore _DB_NOT_UTF8

Post by onorato »

Fatto, ma da lo stesso errore

alfa24
Senior Boarder
Posts: 966
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Errore _DB_NOT_UTF8

Post by alfa24 »

Esegui questa query sul db e posta il risultato:

show variables like 'character_set_database'
I'm Jasmines, the One. If you need, you can contact me.

onorato
Newbie
Posts: 22
Joined: Sun Feb 22, 2015 7:44 pm

Re: Errore _DB_NOT_UTF8

Post by onorato »

Allego immagine
Attachments
Immagine.jpg

onorato
Newbie
Posts: 22
Joined: Sun Feb 22, 2015 7:44 pm

Re: Errore _DB_NOT_UTF8

Post by onorato »

Variable_name
Value
character_set_database
latin1

alfa24
Senior Boarder
Posts: 966
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Errore _DB_NOT_UTF8

Post by alfa24 »

quindi NON è utf8
ALTER DATABASE databasename CHARACTER SET utf8 COLLATE utf8_general_ci;
I'm Jasmines, the One. If you need, you can contact me.

onorato
Newbie
Posts: 22
Joined: Sun Feb 22, 2015 7:44 pm

Re: Errore _DB_NOT_UTF8

Post by onorato »

Ok. Risolto.
Ma è un bug di Aruba?

onorato
Newbie
Posts: 22
Joined: Sun Feb 22, 2015 7:44 pm

Re: Errore _DB_NOT_UTF8

Post by onorato »

Ora mi chiede di disattivare strict mode di MySQL
Come faccio?

alfa24
Senior Boarder
Posts: 966
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Errore _DB_NOT_UTF8

Post by alfa24 »

I'm Jasmines, the One. If you need, you can contact me.

Post Reply