problema con campo supplementare

Domande sulle funzionalità di backend: amministrazione utenti e corsi, certificati, iscrizioni, report, ...
Post Reply
asteron
Newbie
Posts: 8
Joined: Wed Apr 16, 2014 4:06 pm

problema con campo supplementare

Post by asteron »

Salve, ho provato a inserire un campo personalizzato, in particolare una tendina con due valori alfanumerici con spazi.
Intanto vorrei sapere se è possibile non farlo apparire in fase di registrazione utente dal momento che dovrebbe essere usato solo dagli amministratori per classificare gli utenti per anno accademico.
In secondo luogo ho provato a popolare questo campo dall'amministrazione (per gli utenti creati prima di inserire in nuovo campo personalizzato) cliccando su modifica nell'elenco utenti, ma in realtà in fase di salvataggio la finestra popup della modifica sembra non salvare la selezione fatta e rimane aperta. Ho provato anche da visualizza (lente di ingrandimento) clicccando poi su modifica visto che mi manda su un'altra interfaccia, ma qui ricevo un esplicito messaggio di errore nell'esecuzione dell'operazione richiesta.
Ne deduco che il problema si presenta per gli utenti che non hanno quel campo già popolato. Visto però che lo vorrei usare in modo che gli utenti non lo compilino all'atto della registrazione mi chiedo se si può usare nel modo che serve a me.
Grazie

Aggiornamento: in realtà ci capisco sempre meno funziona ogni tanto e solo con gli utenti che hanno già il campo popolato, altre volte da erroe anche con questi

alfa24
Senior Boarder
Posts: 734
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: problema con campo supplementare

Post by alfa24 »

Sempre log degli errori.
Così è impossibile replicare.
Di sicuro se è così random, dipende dal contenuto del campo, quindi inizio a pensare ad apostrofi o altri caratteri speciali.
Se hai bisogno di debug sulla tua istanza contattami in privato.
I'm Jasmines, the One. If you need, you can contact me.

User avatar
max
FormaLms Guru
Posts: 2264
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: problema con campo supplementare

Post by max »

asteron wrote:
Wed Mar 25, 2020 3:30 pm
Salve, ho provato a inserire un campo personalizzato, in particolare una tendina con due valori alfanumerici con spazi.
Intanto vorrei sapere se è possibile non farlo apparire in fase di registrazione utente dal momento che dovrebbe essere usato solo dagli amministratori per classificare gli utenti per anno accademico.
In secondo luogo ho provato a popolare questo campo dall'amministrazione (per gli utenti creati prima di inserire in nuovo campo personalizzato) cliccando su modifica nell'elenco utenti, ma in realtà in fase di salvataggio la finestra popup della modifica sembra non salvare la selezione fatta e rimane aperta. Ho provato anche da visualizza (lente di ingrandimento) clicccando poi su modifica visto che mi manda su un'altra interfaccia, ma qui ricevo un esplicito messaggio di errore nell'esecuzione dell'operazione richiesta.
Ne deduco che il problema si presenta per gli utenti che non hanno quel campo già popolato. Visto però che lo vorrei usare in modo che gli utenti non lo compilino all'atto della registrazione mi chiedo se si può usare nel modo che serve a me.
Grazie

Aggiornamento: in realtà ci capisco sempre meno funziona ogni tanto e solo con gli utenti che hanno già il campo popolato, altre volte da erroe anche con questi
a) se non vuoi far apparire il campo in fase di registrazione, è sufficiente metterlo come invisibile agli utenti. Poi non so come sia configurata la tua policy di registrazione, quindi non aggiungo altro
b) è possibile che su questo campo tu abbia flaggato (in assegnazione campi al nodo) "user inherit"?
Attendo risposte, poi sposterò il thread perchè non mi pare sia un bug quello che descrivi
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

Post Reply