The Elearning Community • Errore di tracciamento e navigazione nei LO
Page 1 of 1

Errore di tracciamento e navigazione nei LO

Posted: Fri Jan 30, 2015 6:05 pm
by zerovirgola618
Buonasera a tutti, sono un vecchissimo utente docebo con una versione 3.5.0.4 su Aruba che ha funzionato senza problemi dal 2008 a ieri.
Oggi gli oggetti didattici SCORM compilati con EXE learning e presenti già da un anno sul server hanno smesso di tracciare i corsisti, rendono a volte impossibile la navigazione al loro interno non restituendo nessun comportamento al click e a volte restituendo il seguente errore:

Fatal error: Call to a member function createTextNode() on a non-object in /web/htdocs/www.---.com/home/doceboLms/modules/scorm5/scorm_tracking.php on line 476

oppure

Fatal error: Call to a member function on a non-object in /web/htdocs/www.---.com/home/doceboLms/modules/scorm/scorm_tracking.php on line 429

A volte l'errore è Internal Server Error.

Non ho apportato alcuna modifica nè al db php, se non le normali operazioni de lettura/scrittura da parte degli utenti che vengono tracciati, nè ai files della piattaforma sul server o ai file degli oggetti didattici.

Dopo un contatto con l'assistenza telefonica che ha operato un downgrade della versione php e un ripristino dei permessi il tutto sembrava risolto ma dopo pochi secondi i poblemi si sono ripresentati.

E' già successo ad altri? Avete qualche idea?
Grazie già da ora a chi vorrà darmi una mano.

Re: Errore di tracciamento e navigazione nei LO

Posted: Fri Jan 30, 2015 6:43 pm
by canelli
Così come descritto sembra che sia un problema legato alle versioni di php utilizzate
Probabilmente è stato fatto un upgrade o sono state modificate delel impostazioni di utilizzo del php.

La tua docebo 3.5.x è molto datata. sarebbe ora per tua comodità e sicurezza passare a Forma 1.3
... L'upgrade diretto in forma.lms 1.3 è supportato dalla versione 3.6.x di docebo ....

claudio

Re: Errore di tracciamento e navigazione nei LO

Posted: Fri Jan 30, 2015 7:20 pm
by zerovirgola618
Grazie Claudio, aruba mi dà la possibilità di scegliere versione di PHP tra 5.2.17, 5.3.29, 5.4.35 e 5.5.19.
Secondo voi quale mi conviene scegliere?
Ora con la 5.2.17 sembra tutto rientrato nei canoni ma è impossibile che abbiano fatto un upgrade dalla 5.2.17 alla 5.5.19... :o

Certo un upgrade mi farebbe comodo, ma con utenti attivi e che frequentano i corsi... non vorrei creare più danni... anche perchè dovrei prima aggiornare a 3.6 e senza assistenza la vedo tragica. Magari su un dominio differente.

GRAZIE MILLE!

Re: Errore di tracciamento e navigazione nei LO

Posted: Fri Jan 30, 2015 9:13 pm
by zerovirgola618
Non ho ancora risolto :(
Da Admin tutto bene da utente mi dice:
Fatal error: Call to a member function createTextNode() on a non-object in /web/htdocs/www.---.com/home/doceboLms/modules/scorm5/scorm_tracking.php on line 476
...e questo solo su un LO, almeno apparentemente gli altri funzionano senza problemi.

Re: Errore di tracciamento e navigazione nei LO

Posted: Fri Jan 30, 2015 9:34 pm
by canelli
con la 3.5.x sicuramente non php 5.4 e 5.5 .
prova la 5.2.17 o la 5.3.29

Per un upgrade dalla 3.5.x a forma.lms ci vuole senz'altro assistenza . Contattami in PM se vuoi

This site uses cookies.

Some of the cookies we use are essential for parts of the site to operate and have already been set. We also use Google Analytics scripts, which all use cookies.
You may delete or block all cookies from this site in your browser options.