Compatibility with Apache 2.4 and PHP 8.1

Install and configure FormaLMS and DoceboCE
Post Reply
JorgeCarousel
Newbie
Posts: 4
Joined: Tue Oct 18, 2022 8:58 pm

Compatibility with Apache 2.4 and PHP 8.1

Post by JorgeCarousel »

Hey guys,

I just downloaded the latest version, put it on an Apache 2.4 with PHP 8.1 and the first thing it did was tell me there were syntax errors in every .htaccess for the lines Order, Deny and Allow; these are deprecated in version 2.4, I replaced them with the new Require all granted or denied, depending on the wrong line, but then when I started the install process, it wasn't able to get the system's information from it, which tells me it's not compatible with PHP 8.1.

I saw a topic saying PHP must be <7.3 but version 7.4 is about to go EOL I believe 7.3 already is, so is this going to be fixed?

Thanks.
User avatar
max
FormaLms Guru
Posts: 2649
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Compatibility with Apache 2.4 and PHP 8.1

Post by max »

- Requiremente: https://docs.formalms.org/reference-gui ... ments.html
- support for php 8.x => in our roadmap and on its way
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it
JorgeCarousel
Newbie
Posts: 4
Joined: Tue Oct 18, 2022 8:58 pm

Re: Compatibility with Apache 2.4 and PHP 8.1

Post by JorgeCarousel »

Thank you, but as I said before PHP v7.4 is about to reach EOL (in November if I remember correctly) so the only option I have is not to use it, at least until it is compatible with PHP 8.x also it would be nice to have it compatible with Apache 2.4 and up, after all version 2.2 has not been updated in a long time, it might also reached EOL.
alfa24
Senior Boarder
Posts: 1672
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Compatibility with Apache 2.4 and PHP 8.1

Post by alfa24 »

Hi, there are not particular directives that won't work with Apache 2.4 (I'm using multiple instances of Forma LMS in Apache 2.4 with no issues).
Regarding PHP, you're absolutely right, 7.4 active support has already ended (28 Nov 2021), while security support will end in 1 month (28 Nov 2022).
I'm Jasmines, the One. If you need, you can contact me.
JorgeCarousel
Newbie
Posts: 4
Joined: Tue Oct 18, 2022 8:58 pm

Re: Compatibility with Apache 2.4 and PHP 8.1

Post by JorgeCarousel »

My Apache httpd 2.4.54 gave error 503, when I checked the log it said:

.htaccess: Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration

And I found that all the .htacess had lines with Order, Allow and Deny which are deprecated in version 2.4
alfa24
Senior Boarder
Posts: 1672
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Compatibility with Apache 2.4 and PHP 8.1

Post by alfa24 »

I'm on Apache 2.4.52 and no problems.
I'm Jasmines, the One. If you need, you can contact me.
JorgeCarousel
Newbie
Posts: 4
Joined: Tue Oct 18, 2022 8:58 pm

Re: Compatibility with Apache 2.4 and PHP 8.1

Post by JorgeCarousel »

You must have access_compat module enabled, You should read this: https://httpd.apache.org/docs/2.4/howto/access.html
alfa24
Senior Boarder
Posts: 1672
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Compatibility with Apache 2.4 and PHP 8.1

Post by alfa24 »

It's enabled.
I'm Jasmines, the One. If you need, you can contact me.
Post Reply