Admin Panel non funzionante

Cosa cambiereste? Che funzionalità aggiungereste? Discutiamone qui ....
alexuggenti
Newbie
Posts: 10
Joined: Mon Oct 24, 2022 3:45 pm

Re: Admin Panel non funzionante

Post by alexuggenti »

perdonami forse non ho spiegato bene cosa intendo,
al momento non ho una precedente installazione, la piattaforma e' online e funzionante a parte l'admin panel
Purtroppo non ho modo di investigare, l'unico errore che ho e' quello di PHP di max execution time su lib.fsock_wrapper.php linea 97.
Non so se puo' essere utile rifare l'installazione della piattaforma puntando alla pagina /install
provandoci, non mi premette di reinstalalre perchè il DB non e' vuoto. Mi chiedevo dunque, esiste un modo per fare una installazione utilizzando il DB corrente, senza doverne creare uno nuovo?
alfa24
Senior Boarder
Posts: 1972
Joined: Fri Nov 24, 2017 8:45 am

Re: Admin Panel non funzionante

Post by alfa24 »

Ripeto.
Fare un'installazione significa partire da zero, ovvero con un DB vuoto.
Fare un upgrade significa avanzare alla versione x+1 dalla versione x, avendo un db alla versione x.
Se non sei in nessuna delle due situazione descritte, né puoi riportarti alla condizione di avere un db (non vuoto) alla versione x per upgradarlo alla x+1, non puoi fare nulla.
Per supporto GRATUITO contattatemi in privato qui
alexuggenti
Newbie
Posts: 10
Joined: Mon Oct 24, 2022 3:45 pm

Re: Admin Panel non funzionante

Post by alexuggenti »

ok chiaro, grazie mille per il supporto!!
alexuggenti
Newbie
Posts: 10
Joined: Mon Oct 24, 2022 3:45 pm

Re: Admin Panel non funzionante

Post by alexuggenti »

volevo dare un aggiornamento
la macchina sopra descritta e' configurata come segue
Ubuntu 20.04
PHP 7.4.3
MariaDB 10.3
non vi e' modo di navigare sulla pagina di admin per l'errore sopra descritto, ipotizzo a seguito di un update OS
- ho provato a cancellare tuto, cartelle, db e ricreare da zero con lo stesso risultato
- ho rifatto una macchina ubuntu 22.04 con PHP7.4 e maria db 10.6, l'installazione di formalms non procede, non rileva il charset UTF8 del db anche se impostato come tale
- ho rifatto una macchina ubuntu 20.04 con php7.4 e mariadb 10.3, l'installazione di formalms riesce, la pagina admin non e' navigabile con l'errore descritto nel primo post

mi sembra che ci sia una incompatibilità con le ultime release di mariadb o ubuntu

Mi sapreste dire se esiste un fix o quale siano i requirement piu' recenti utilizzabili?
alfa24
Senior Boarder
Posts: 1972
Joined: Fri Nov 24, 2017 8:45 am

Re: Admin Panel non funzionante

Post by alfa24 »

Ciao,
PHP 7.4 e mariadb 10.4 con collation utf-8 è ok.
Tuttavia nel tuo caso suppongo ci sia altro che non si riesce a investigare su un forum.
Per supporto GRATUITO contattatemi in privato qui
alexuggenti
Newbie
Posts: 10
Joined: Mon Oct 24, 2022 3:45 pm

Re: Admin Panel non funzionante

Post by alexuggenti »

purtroppo e' difficile investigare in genere, non ci sono errori mysql, non ci sono errori apache a parte:
PHP Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/formalms/lib/lib.fsock_wrapper.php on line 97, referer: https://learning.sito.it/appLms/index.p ... rning/show

la macchina ubuntu e' preparata da zero senza nessuna configurazione particolare...
l'uncia cosa che differisce dalle istruzioni che seguo e' che il servizio e' in https invece di http, ma impostandolo in http il risultato non cambia, se puo' essere utile, incollo tutte le istruzioni lanciate sulla macchina per installare il servizio.
Mi dispiacerebbe dover rinunciare a Forma LMS come soluzione
alfa24
Senior Boarder
Posts: 1972
Joined: Fri Nov 24, 2017 8:45 am

Re: Admin Panel non funzionante

Post by alfa24 »

Quello che voglio dire è che non possiamo darti supporto sistemistico su un forum.
Se hai bisogno di aiuto, scrivimi in privato.
Per supporto GRATUITO contattatemi in privato qui
alexuggenti
Newbie
Posts: 10
Joined: Mon Oct 24, 2022 3:45 pm

Re: Admin Panel non funzionante

Post by alexuggenti »

grazie mille
Post Reply